Author Topic: Win7/8 compatible dgvoodoo  (Read 5376 times)

Comptroller

  • Team Redux
  • ****
  • Posts: 9
    • View Profile
Win7/8 compatible dgvoodoo
« on: January 05, 2015, 02:23:51 AM »
In case you didn't know this,  dege is still updating his glide wrapper.  Current version 2.4 was just released Nov 2014!  http://dege.freeweb.hu/

Von S

  • Newbie
  • *****
  • Posts: 5
    • View Profile
    • WWI Flight Sims on a Mac
Re: Win7/8 compatible dgvoodoo
« Reply #1 on: January 05, 2015, 12:08:54 PM »
Interesting stuff, will test in WineSkin, although I swear by 1.50 Beta 2 - it gives 60 fps and is stable. Maybe this gives more eye candy (2.4), although it may be overkill for RB3D.

Happy flying,
Von S
__________
CombatAce Member Page
https://combatace.com/profile/86760-vons/

Comptroller

  • Team Redux
  • ****
  • Posts: 9
    • View Profile
Re: Win7/8 compatible dgvoodoo
« Reply #2 on: January 05, 2015, 01:29:00 PM »
Well one of the features it has now is the ability to use DX11,  so the newest cards are supported if using native drivers.  Not sure if it would be any use under wine however.

Von S

  • Newbie
  • *****
  • Posts: 5
    • View Profile
    • WWI Flight Sims on a Mac
Re: Win7/8 compatible dgvoodoo
« Reply #3 on: January 05, 2015, 08:09:00 PM »
Some quick results on running dgVoodoo 2.4 in WineSkin:

(a) the 2.4 "glide2x.dll" file crashes RB3D, splash screen loads and then freezes

(b) regular 2.4 "glide3x.dll" file not recognized, game plays in DirectDraw mode

(c) napalm 2.4 "glide3x.dll" file not recognized, game plays in DirectDraw mode

The glide3x.dlls are too new for RB3D to recognize (glide 2.x was probably just out when RB3D was popular). Anyway, will be sticking with 1.50 Beta 2 in the wrappers.

Von S
__________
CombatAce Member Page
https://combatace.com/profile/86760-vons/

Comptroller

  • Team Redux
  • ****
  • Posts: 9
    • View Profile
Re: Win7/8 compatible dgvoodoo
« Reply #4 on: January 06, 2015, 03:24:59 AM »
Just tested 2.4 under win7 64 bit,  works fine.  Needs a huge amount of tweaking first though.  When I get time I'll make a tweaked version of this like I did for the older ones.  Just a tip,  when I run stuff like this,  I left click,  and select "run as administrator".  Sometimes helps.

Comptroller

  • Team Redux
  • ****
  • Posts: 9
    • View Profile
Re: Win7/8 compatible dgvoodoo
« Reply #5 on: January 06, 2015, 03:51:33 AM »
Did further testing,  and under win7 64 bit,  I agree 1.50b2 works best.  It seems the newer versions do nothing for RB3D.  I can still get full 1600x1200 glide under win7 with 1.50b2 and FCJCP.  Ah remember the days...  full canvas jacket,  coldwar....  even the tourneys....

Von S

  • Newbie
  • *****
  • Posts: 5
    • View Profile
    • WWI Flight Sims on a Mac
Re: Win7/8 compatible dgvoodoo
« Reply #6 on: January 06, 2015, 03:48:59 PM »
1600 x 1200 resolution is mighty fine, I usually stick with 1280 x 1024 so I can window the whole thing in WineSkin on HD (1920 x 1080) screens. Yeah 1.50 Beta2 is about as good as it gets for RB3D.

What I'd like to figure out is a hack to get RB3D running in widescreen mode (16:9 ratio) at, say, 1600 x 900, or 1920 x 1080 resolution. That would be golden - but maintaining the normal aspect ratio of the game (no wide planes and junk like that).

Von S
__________
CombatAce Member Page
https://combatace.com/profile/86760-vons/

SwampFox

  • Team Redux
  • ****
  • Posts: 22
    • View Profile
Re: Win7/8 compatible dgvoodoo
« Reply #7 on: January 07, 2015, 02:14:24 PM »
The sad thing is, Von S, in our work a year and a half ago, singleplayer became full width hi-def.  The cockpits would have to be re-done, but then all graphics would need updating.   The plane models would have to stay at the poly level of whatever the best SWWISA planes came to, but the texturing can be unlimited.

Alas, this wonderful thing sit "on the shelf" and probably always will.  Can you imagine what people would have thought about having that opportunity back in the SWWISA days??

Swamp

Von S

  • Newbie
  • *****
  • Posts: 5
    • View Profile
    • WWI Flight Sims on a Mac
Re: Win7/8 compatible dgvoodoo
« Reply #8 on: January 07, 2015, 03:44:58 PM »
...widescreen RB3D back in the SWWISA days...that would have been nice...ah, maybe the ball will start rolling once again and RB3D will find its spot as one of the great new flight sims with a long and wonderful history...let's hope some smart coders interested in RB3D get inspired by the game and the great possibilities to modernize it. RB3D has a kind of charm that OFF/WOFF and ROF sadly lack. FE2 is acceptable but man does that FM need lots of tweaking in FE2 for it to fly the planes realistically.

...on an unrelated note, been testing WINE on LinuxMint (Ubuntu based)...and boy WINE is really finicky on it...the FCJCP loads, but dgVoodoo 1.5 Beta 2 and the Baron.exe crash...will have to test more to see if the Linuxes are friendly with RB3D. Macs are good with WineSkin. Rens' I think had a page years ago where he showed how the game runs on OpenSuse...maybe it works on some distros but not others...

Happy flying gents',
Von S
__________
CombatAce Member Page
https://combatace.com/profile/86760-vons/